use strict;
my $str = 'seq_read_4k: (groupid= 0 jobs= 1): err= 0: pid= 7396: Wed Sep 2 14:07:25 2015
read : io= 72013 MB bw= 614510 KB/s iops= 153627 runt= 120001msec
--
seq_read_128k: (groupid= 1 jobs= 1): err= 0: pid= 7463: Wed Sep 2 14:07:25 2015
read : io= 74277 MB bw= 633821 KB/s iops= 4951 runt= 120001msec
--
rand_read_4k: (groupid= 2 jobs= 1): err= 0: pid= 7480: Wed Sep 2 14:07:25 2015
read : io= 4102.4 MB bw= 35006 KB/s iops= 8751 runt= 120001msec
--
rand_read_1M: (groupid= 3 jobs= 1): err= 0: pid= 7497: Wed Sep 2 14:07:25 2015
read : io= 44963 MB bw= 383678 KB/s iops= 374 runt= 120002msec
';
my $regex = qr/\(groupid=\s+(?P<groupid>\d+)/up;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}