package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\'\(\)]?(abba)[\'\(\)]?`)
var str = `my band 'abba' is the shit`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}