#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?<=\w)\s{20}"
Local $sString = "Ateles_geoffroyi GATGAGTGTGGCAAGGCCCAAGCGGAAGTGCCG--GTTGCT" & @CRLF & _
"Ateles_hybridus GATGAGTGTGGCAAGGCCCAAGCGGAAGTGCCG--GTTGCT" & @CRLF & _
"Ateles_fusciceps GATGAGTGTGGCAAGGCCCAAGCGGAAGTGC??????????" & @CRLF & _
"Ateles_chamek GATGAGTGTGGCAAGGCCCA?????????????????????" & @CRLF & _
"Ateles_paniscus ?????????????????????????????????????????" & @CRLF & _
"Brachyteles_arachnoides GATGAGTGTGGCAAGGCCCAAGCGGAAGT????????????" & @CRLF & _
"Brachyteles_hypoxanthus GATGAGTGTGGCAAG??????????????????????????" & @CRLF & _
"Lagothrix_cana GATGAGTGTGGCAAGGCCCAAGCGGAAGTGCCG--GTTGCT" & @CRLF & _
"Lagothrix_lagotricha GATGAGTGTGGCAAGGCCCAAGCGGAAGTGCCG--GTTGCT" & @CRLF & _
"Alouatta_belzebul ?????????????????????????????????????????" & @CRLF & _
"Alouatta_caraya ?????????????????????????????????????????" & @CRLF & _
"Alouatta_sara GATGAATGTGGCAAGGCCCAAGCAGAAGTGCCG--GTTGCT" & @CRLF & _
"Alouatta_palliata GATGAATGTGGCAAGGCCCAAGCAGAAGTGCCG--GTTGCT" & @CRLF & _
"Callicebus_brunneus ?????????????????????????????????????????" & @CRLF & _
"Callicebus_moloch GATGAGTGTGGCAAGGCCCAAGCAGAAGTGCCG--G?????" & @CRLF & _
"Callicebus_cupreus GATGAGTGTGGCAAGGCCCAAGCAGAAGTGCCG--GTTGCT" & @CRLF & _
"Callicebus_caligatus GATGAGTGTGGCAAGGCCCAAGCAGAAGTGCCG--GTTGCT" & @CRLF & _
"Callicebus_donacophilus GATGAGTGTGGCAAGGCCCAAGCAGAAGTGCCG--GTTGCT" & @CRLF & _
"Callicebus_coimbrai GATGAGTGTGGCAAGGCCCAAGCGGAAGTGCCG--GTTGCT" & @CRLF & _
"Callicebus_personatus GATGAGTGTGGCAAGGCCCAAGCGGAA??????????????" & @CRLF & _
"Callicebus_nigrifrons GATGAGTGTGGCAAGGCCCAAGCGGAAGTGCCG--GTTGCT" & @CRLF & _
"Cacajao_melanocephalus GATGAGTGTGGCAAAGCCCA?????????????????????" & @CRLF & _
"Cacajao_calvus GATGAGTGTGGCAAGGCCCAAGCGGAAGTGCCG--GTTGCT" & @CRLF & _
"Chiropotes_israelita GATGAGTGTGGCAAGGCCCAAGCGGAAGTGCCG--GTTGCT" & @CRLF & _
"Chiropotes_satanas_chiro ?????????????????????????????????????????" & @CRLF & _
"Pithecia_irrorata GATGAGTGTGGCAAGGCCCAAGCGGAAGTGCCG--G?????" & @CRLF & _
"Pithecia_pithecia GATGAGTGTGGCAAGGCCCAAGCGGAAGTGCCG--GTTGCT" & @CRLF & _
"Tarsius_bancanus ?????????????????????????????????????????" & @CRLF & _
"Tarsius_syrichta ?????????????????????????????????????????" & @CRLF & _
"Lepilemur_ankaranensis AACGAGTGTGGCAAGGCCCAGGCGGAAGTTCCG--GTTGCT" & @CRLF & _
"Lepilemur_septentrionali AACGAGTGTGGCAAGGCCCAGGCGGAAGTTCCG--GTTGCT" & @CRLF & _
"Lepilemur_dorsalis AACGAGTGTGGCAAGGCCCAGGCGGAAGTTCCG--GTTGCT" & @CRLF & _
"Lepilemur_ruficaudatus AACGAGTGTGGCAAGGCCCAGGCGGAAGTTCCG--GTTGCT" & @CRLF & _
"Lepilemur_jamesi AACGAGTGTGGCAAGGCCCAGG???????????????????" & @CRLF & _
"Microcebus_murinus_subsp AACGAGTGTGGCAAGGCCCAGGCGGAAGTTCCG--GTTGCT" & @CRLF & _
"Microcebus_murinus_subsp ?????????????????????????????????????????" & @CRLF & _
"Mirza_zaza AACGAGTGTGGCAAGGCCCAGGCAGAAGTTCCG--GTTGCT" & @CRLF & _
"Cheirogaleus_medius ?????????????????????????????????????????" & @CRLF & _
"Propithecus_verreauxi_co ?????????????????????????????????????????" & @CRLF & _
"Propithecus_verreauxi AACGAGTGTGGCAAGGCCCAGGCGGAAGTTCCG--GTTGCT" & @CRLF & _
"Propithecus_tattersalli AACGAGTGTGGCAAGGCCCAGGCTGAAGTTCCG--GTTGCT" & @CRLF & _
"Propithecus_diadema AACGAGTGTGGCAAGGCCCAGGCGGAAGTTCCG--GTTGCT" & @CRLF & _
"Propithecus_edwardsi AACGAGTGTGGCAAGGCCCAGGCG?????????????????" & @CRLF & _
"Avahi_laniger AACGAGTGTGGCAAGGCCCAGGCGGAAGTTCCG--GTTGCT" & @CRLF & _
"Eulemur_rufus AACGAGTGTGGCAAGGCCCAGGCGGAAGTTCCG--GTTGCT" & @CRLF & _
"Eulemur_collaris AACGAGTGTGGCAAGGCCCAGGCGGAAGTTCCG--GTTGCT" & @CRLF & _
"Eulemur_fulvus AACGAGTGTGGCAAGGCCCAGGCGGAAGTTCCG--GTTGCT" & @CRLF & _
"Eulemur_albifrons AACGAGTGTGGCAAGGCCCAGGCGGAAGTTCCG--GTTGCT" & @CRLF & _
"Eulemur_sanfordi AACGAGTGTGGCAAGGCCCAGGCGGAAGTTCCG--GTTGCT" & @CRLF & _
"Eulemur_mongoz AACGAGTGTGGCAAGGCCCAGGCGGAAGTTCCG--GTTGCT" & @CRLF & _
"Eulemur_macaco AACGAGTGTGGCAAGGCCCAGGCGGAAGTTCCG--GTTGCT" & @CRLF & _
"Eulemur_macaco_flavifron AACGAGTGTGGCAAGGCCCAGGCGGAAGTTCCG--GTTGCT" & @CRLF & _
"Eulemur_coronatus AACGAGTGTGGCAAGGCCCAGGCGGAAGTTCCG--GTTGCT" & @CRLF & _
"Eulemur_rubriventer AACGAGTGTGGCAAGGCCCAGGCGGAAGTTCCG--GTTGCT" & @CRLF & _
"Hapalemur_occidentalis AACGAGTGTGGCAAGGCCCAGGCGGAAGTTCCG--GTTGCT" & @CRLF & _
"Hapalemur_griseus AACGAGTGTGGCAAGGCCCAGGCGGAAGTTCCG--GTTGCT" & @CRLF & _
"Lemur_catta AACGAGTGTGGCAAGGCCCAGGCGGAAGTTCCG--GTTGCT" & @CRLF & _
"Varecia_variegata_varieg AACGAGTGTGGCAAGGCCCAGGCAGAAGTTCCG--GTTGCT" & @CRLF & _
"Varecia_variegata_rubra AACGAGTGTGGCAAGGCCCAGGCAGAAGTTCCG--GTTGCT" & @CRLF & _
"Daubentonia_madagascarie ?????????????????????????????????????????" & @CRLF & _
"Nycticebus_bengalensis AACGAGTGTGGCAAGGCCCAGGCAGAAGTTCCG--GTTGCT" & @CRLF & _
"Nycticebus_coucang AACGAGTGTGGCAAGGCCCAGGCAGAAGTTCCG--GTTGCT" & @CRLF & _
"Nycticebus_pygmaeus AACGAGTATGGCAAGGCCCAGGCAGAAGTTCCG--GTTGCT" & @CRLF & _
"Loris_tardigradus AACGAGTGTGGCAAGGCCCAGGCAGAAGTTCCG--GTTGCT" & @CRLF & _
"Arctocebus_calabarensis AACGAGTGTGGCAAGGCCCAGGCAGAAGTTCCG--GTTGCT" & @CRLF & _
"Perodicticus_potto AACGAGTGTGGCAAGGCCCAGGCAGAAGTTCCG--GTTGCT" & @CRLF & _
"Otolemur_garnetti AACGAGTGTGGCAAGGCCCAGGCAGAAGTTCCG--GTTGCT" & @CRLF & _
"Otolemur_crassicaudatus AACGAGTGTGGCAAGGCCCAGGCAGAAGTTCCG--GTTGCT" & @CRLF & _
"Galago_moholi ?????????????????????????????????????????" & @CRLF & _
"Galago_senegalensis ?????????????????????????????????????????" & @CRLF & _
"Galago_thomasi AACGAGTGTGGCAAGGCCCAGGCG?????????????????" & @CRLF & _
"Galeopterus_variegatus GATGAGTGTGGCAAGGCCCAAGCAGAAGTTCCG--G?????" & @CRLF & _
"Cynocephalus_volans GATGAGTGTGGCAAGGCCCAAGCAGAAGTCCCG--GTTGCT" & @CRLF & _
"Tupaia_glis ?????????????????????????????????????????" & @CRLF & _
"Tupaia_minor ?????????????????????????????????????????" & @CRLF & _
"rabbit_rabbit_rabbit ?????????????????????????????????????????" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")