# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"balance\"\:\"([0-9]{1,})\"\,\"settings"
test_str = "[200,{\"cookie\":\"623218:b4693930b241d92abcd866afd3a48090ee213570\",\"user\":{\"id\":\"623218\",\"name\":\"null\",\"email\":\"knight-war@hotmail.com\",\"api_key\":\"09cafaaa34299398474bb6bdff7e02a2a7fb6fda\",\"premium\":\"Thu Oct 09 2014 17:39:15 GMT+0000 (UTC)\",\"premium_unix\":\"1412876355\",\"webspace\":53687091200,\"traffic\":{\"current\":1099511627776,\"increase\":0,\"last\":1413569003,\"max\":0},\"balance\":\"0\",\"settings\":{},\"external_id\":\"null\",\"ftp_username\":\"ftp623218\",\"partner\":\"3\",\"partner_last\":\"1413025653\",\"allow_dupe_names\":\"0\"},\"session\":\"45af19f7-4d90-40ad-b90e-d98fa22ba15c\"}]1"
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.