#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=^(?:(\d\d(?:[02468][048]|[13579][26]))-02-29|\d{4}-(?:0[13578]|1[02])-31|\d{4}-(?:0[13-9]|1[0-2])-30|\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|1\d|2[0-8])))(\d{4})-(\d\d?)-(\d\d?)(?:\x20(\d{2}):(\d{2})(?::(\d{2})(.\d+)?)?)?$"
Local $sString = "This captures the year, month and day of a date at the 2nd, 3rd and 4th groups." & @CRLF & _
"Also captures leap years in day 29 of February in 1st capturing group." & @CRLF & _
"2014-05-31" & @CRLF & _
"2016-02-29" & @CRLF & _
"2004-08-10 13:02" & @CRLF & _
"2002-02-08 19:35:00" & @CRLF & _
"1999-12-31 23:59:59.999" & @CRLF & _
"1996-02-29 23:59:59.9999" & @CRLF & _
"Regex used: ^(?=^(?:(\d\d(?:[02468][048]|[13579][26]))-02-29|\d{4}-(?:0[13578]|1[02])-31|\d{4}-(?:0[13-9]|1[0-2])-30|\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|1\d|2[0-8]))$)(\d{4})-(\d\d?)-(\d\d?)$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")