$re = '/\[([^\]]+)/';
$str = '10:11:22 [UTP][ROX][ID:32424][APP STR]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);