$re = '/(?<src_ip>\d{0,2}\.\d{0,2}\.\d{0,2}\.\d{0,2})\s(?<signture>%(?<product>ASA))-(?<version>(?<release>\d+)-(?<build>\d+)):/';
$str = 'May 9 14:30:00 10.25.8.3 %ASA-6-302013: Built outbound TCP connection 1032748840 for MGM-CML-NON-LB-SRV-Log:10.25.3.21/9997 (10.25.3.21/9997) to MIT-IBMgmt-NW:10.70.21.165/4379 (10.70.21.165/4379)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);