package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(\.\d{2})?$`)
var str = `12.72`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}