package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(0|\+98)?([ ]|-|[()]){0,2}9[1|2|3|4]([ ]|-|[()]){0,2}(?:[0-9]([ ]|-|[()]){0,2}){7}`)
var str = `+98935123456
0935123456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}