#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?<=จังหวัด\s)|(?<=จังหวัด)|(?<=จ\.\s)|(?<=จ\.)|(?<=จ\s))([ก-๙]+)|(กรุงเทพ[มหานคร]*)|(กทม)"
Local $sString = "ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง จ.อุบล 34000" & @CRLF & _
"ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง จังหวัดอุบล 34000" & @CRLF & _
"ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง จ. อุบล 34000" & @CRLF & _
"ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง จังหวัด อุบล 34000" & @CRLF & _
"ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง กรุงเทพ 34000" & @CRLF & _
"ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง กทม 34000" & @CRLF & _
"ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง จังหวัดกรุงเทพมหานคร 34000" & @CRLF & _
"ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง กทม. 34000" & @CRLF & _
"ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง กรุงเทพมหานคร34000" & @CRLF & _
"ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง จ อุบล 34000" & @CRLF & _
"ราตรี แสนเล็ก 39หมู่11ซ.บูรพา1 แม่กุ แม่สอด ตาก 63110 0924468731" & @CRLF & _
"กันธิชา. ฤกษจันทร์ 64/10พุนพินมะลวนสุราษฎร์ธานี8413066936166649, พุนพิน"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")