package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https://www.filmxy.vip/movie/(.*[^/])`)
var str = `https://www.filmxy.vip/movie/chupkotha`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}