package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^.*[\/\\]`)
var str = `/bla/bla/folder/file.part.1.file`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}