re = /(\babstract\b)|(\bassert\b)|(\bboolean\b)|(\bbreak\b)|(\bbyte\b)|(\bcase\b)|(\bcatch\b)|(\bchar\b)|(\bclass\b)|(\bconst\b)|(\bcontinue\b)|(\bdefault\b)|(\bdouble\b)|(\bdo\b)|(\belse\b)|(\benum\b)|(\bextends\b)|(\bfalse\b)|(\bfinal\b)|(\bfinally\b)|(\bfloat\b)|(\bfor\b)|(\bgoto\b)|(\bif\b)|(\bimplements\b)|(\bimport\b)|(\binstanceof\b)|(\binterface\b)|(\bint\b)|(\blong\b)|(\bnative\b)|(\bnew\b)|(\bnull\b)|(\bpackage\b)|(\bprivate\b)|(\bprotected\b)|(\bpublic\b)|(\breturn\b)|(\bshort\b)|(\bstatic\b)|(\bstrictfp\b)|(\bsuper\b)|(\bswitch\b)|(\bsynchronized\b)|(\bthis\b)|(\bthrows\b)|(\bthrow\b)|(\btransient\b)|(\btrue\b)|(\btry\b)|(\bvoid\b)|(\bvolatile\b)|(\bwhile\b)/m
str = 'void
main
printf
void/
public
scanf
super'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end