using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(https?://)?((www\.)?t(elegram)?\.(dog|me)/((?![_\d])(?!.*__)(?!.*_$)\w{4,}[a-z\d]|[\w\+-]{13,17})|(?![_\d])(?!.*__)(?!.*_$)\w{4,}[a-z\d]\.(t(elegram)?\.(dog|me)))";
string input = @"https://t.me/+-k0L3asdxMc2Mjc8
https://t.me/telegram
telegram.t.me
telegram.telegram.me
t.me/telegram
https://www.t.me/+-k0L3asdxMc2Mjc8
telegram.t.me
tel_egram.t.me
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}