$re = '/(?x)
<p>.*?<\/p>/m';
$str = '<p>Paragraph 1</p><p>Paragraph 2</p><p>Paragraph 3</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);