use strict;
my $str = 'YP-A-Ss_25_10_20-M3-CWS-Curtain_Wall-LOD200';
my $regex = qr/[A-Z]{2}[-|_][A-Z]{1}[-|_][a-zA-Z]{2}[-|_][0-9]{2}[-|_][0-9]{2}[-|_][0-9]{2}[-|_][0-9A-Z]{2}[-|_][A-Z]{3}[-|_][\w]{1,30}[-|_]LOD[0123]00/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";