package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)[^,]?+`)
var str = `1, 2 , 3 ,4,
4, 345, 88`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}