const regex = /(.*[^"]+((?<=[.?!]\s).*lockbox.*(?<=[.?!]))[^"].*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*[^"]+((?<=[.?!]\\s).*lockbox.*(?<=[.?!]))[^"].*)', 'g')
const str = `"krombacher alkoholfrei mw. 24 x 0,33 l bier krombacher alkoholfrei alkohol ist entbehrlich, geschmack nicht das krombacher pilsener alkoholfrei ist eine vollmundige erfrischung. bierkenner werden von dem erfrischend isotonischen durstlöscher überzeugt sein, denn es ist das beliebteste alkoholfreie pils in deutschland. abgefüllt wird es in der 0,33 l mehrwegflasche mit 24 flaschen pro kiste. bestell noch heute bis 23.30 uhr und wir liefern schon morgen mit dem einzigartigen lockboxsystem. Und so weiter.";
"krombacher alkoholfrei mw. 24 x 0,33 l bier krombacher alkoholfrei alkohol ist entbehrlich, geschmack nicht das krombacher pilsener alkoholfrei ist eine vollmundige erfrischung. bierkenner werden von dem erfrischend isotonischen durstlöscher überzeugt sein, denn es ist das beliebteste alkoholfreie pils in deutschland. abgefüllt wird es in der 0,33 l mehrwegflasche mit 24 flaschen pro kiste. bestell noch heute bis 23.30 uhr und wir liefern schon morgen mit dem einzigartigen lockboxsystem. Und so weiter.";`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}