const regex = /^(?<ip>[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}).*(?<mac>..:..:..:..:..:..)\s*.\s*(?<interface>.*)$/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<ip>[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}).*(?<mac>..:..:..:..:..:..)\\s*.\\s*(?<interface>.*)$', 'm')
const str = `192.168.87.2 0x1 0x2 0f:50:56:e3:9e:6a * wlan0
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}