import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:http(?:s?)|socks(?:5|5h))://(?:[A-Za-z0-9]*:[A-Za-z0-9]*@)*(?:\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}):(?:\\d{2,5})";
final String string = "http://aozijqzx:1lqmg4uww14f@185.199.229.156:7492http://aozijqzx:1lqmg4uww14f@185.199.228.220:7300";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}