$re = '/(?:^|\s)\w/';
$str = 'How can mirrors be real if our eyes aren\'t real';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);