$re = '/^(([\w\-\.]*)@([\w\.]*[.][\w]{2,3}))$/';
$str = 'me@ruben.co.uk';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);