$re = '/^(https?|ftp)\:\/\/+([www]){3}\.([a-z0-9.])+\.([a-z]){2,3}$/';
$str = 'http://www.facebook.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);