re = /(\b\d+(?:[\.,]\d+)?\b(?!(?:[\.,]\d+)|(?:\s*(?:%|percent))))/m
str = '5000026237 smart coins Redeemable'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end