$re = '/[+-]?\d+/';
$str = '1, 2, 65, 2579, etc.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);