$re = '/^[^\s#]+$/m';
$str = 'Some string
#hashtag
No-space-chunk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);