package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(1Z ?[0-9A-Z]{3} ?[0-9A-Z]{3} ?[0-9A-Z]{2} ?[0-9A-Z]{4} ?[0-9A-Z]{3} ?[0-9A-Z]|[\dT]\d\d\d ?\d\d\d\d ?\d\d\d)\b`)
var str = `1Z5718450452165989`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}