$re = '/(\([-+]?0*[1-9]+,[-+]?0+[1-9]+\),)/m';
$str = '(01,03),(+1,00003),';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);