$re = '/\d+(?=\/)/';
$str = 'https://www.e2etest.xxx.yyy.com/order/80012805/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);