$re = '/((?:(?(?=(e.g.|z.b.|Figs?\.|\d+\.\d))\2|[^.!?])+[.!?]))/i';
$str = 'Test 10. Testing. Testing. Fig. 20. The decimal 20.3 should 20 still be sentence.Ok now. try 2.3. Explained reference to Figs. 2 and 3. ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);