package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`( )\bHappyCoding`)
var str = `This is example for HappyCoding
Yes! HappyCoding
HappyCoding`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}