# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?:dictad|pronunciad)(?:a|o)) por (?:don |doña )?([\w\s]+), juez(?:a?) (?:suplente)?"
test_str = ("Dictada por don ARMANDO FREDY PUELLES ROJAS, Juez Suplente del Juzgado de Letras, Garantía, Familia, y del Trabajo de Taltal\n\n"
"Dictada por ARMANDO FREDY PUELLES ROJAS, Juez Suplente del Juzgado de Letras, Garantía, Familia, y del Trabajo de Taltal\n\n"
"Dictada por ARMANDO FREDY PUELLES ROJAS, Juez del Juzgado de Letras, Garantía, Familia, y del Trabajo de Taltal\n\n"
"V-1560-2018 Foja: 1 Dictada por don ARMANDO FREDY PUELLES ROJAS, Juez Suplente del Juzgado de Letras, Garantía, Familia, y del Trabajo de Taltal\n\n"
"Dictada por doña SANDRA JANETT ORELLANA ARAYA, Jueza Suplente del Primer Juzgado de Letras de Vallenar',")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.