$re = '/^6[05]\d{8,10}$/';
$str = '651231231233
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);