// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)(\"WAFFlags\":\"1\"|\"FirewallMatchesActions\":\[\"log\"\]|\"FirewallMatchesActions\":\[\"log\",\"log\"\]|\"FirewallMatchesSources\":\[\"firewallRules\",\"waf\"\]|\"FirewallMatchesActions\":\[\"block\"\]|\"FirewallMatchesActions\":\[\"challengeSolved\"\]|\"FirewallMatchesActions\":\[\"challenge\"\])"#).unwrap();
let string = "\"WAFFlags\":\"1\"
\"FirewallMatchesActions\":[\"log\"]
\"FirewallMatchesActions\":[\"log\",\"log\"]
\"FirewallMatchesSources\":[\"firewallRules\",\"waf\"]
\"FirewallMatchesActions\":[\"block\"]
\"FirewallMatchesActions\":[\"challengeSolved\"]
\"FirewallMatchesActions\":[\"challenge\"]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}