re = /<([a-z]+)([^<]+)*(?:>(.*)<\/\1>|\s+\/>)/m
str = '<a>match only <b>the corresponding</b> tag</a> even if there is other <b> text </b>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end