import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^|\\s)(@[\\w.]+)(?<!\\.)";
final String string = "Hello, @username\n"
+ "Hello, @username.\n"
+ "Hello, @user.name.\n"
+ "Go to https://google.com/@username\n"
+ "@username says hello.\n"
+ "@user.name says hello.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}