const regex = /(?P<req_ip>^.+)\s+(?P<req_identity>.+?)\s+(?P<req_user>.+?)\s+\[(?P<req_date>.+?)\]\s+"(?P<req_method>.+?)\s+(?P<req_path>.+?)\s+(?P<req_protocoll>.+?)"\s+(?P<req_code>.+?)\s+(?P<req_size>.+?)\s+"(?P<req_referer>.+?)"\s+"(?P<req_device>.+?)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<req_ip>^.+)\\s+(?P<req_identity>.+?)\\s+(?P<req_user>.+?)\\s+\\[(?P<req_date>.+?)\\]\\s+"(?P<req_method>.+?)\\s+(?P<req_path>.+?)\\s+(?P<req_protocoll>.+?)"\\s+(?P<req_code>.+?)\\s+(?P<req_size>.+?)\\s+"(?P<req_referer>.+?)"\\s+"(?P<req_device>.+?)"', 'gm')
const str = `165.72.105.195 - - [11/May/2021:14:14:14 +0000] "POST /us/en/registration.html HTTP/1.1" 500 1676 "https://my.domain.com/us/en/registration.html" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.44 Safari/537.36 OPR/69.0.3686.7 (Edition beta)"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}