re = /([?&][^=]*=)([^&]*)/
str = 'http://example.com/test/index.php?param=test&a=1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end