package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+)\s*(\w+)\s*(.)\s*(\w+)`)
var str = `int a = 0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}