$re = '/((19\d\d|20\d\d)-(0\d|1[0-2])-([0-2]\d|30|31))T((\d{2}):(\d{2}):(\d{2}))(?:\.(\d{3,6}))?(?:((?:([+-])(?:(0\d|1[012]))):?([0-5]\d))|Z?)/';
$str = '2008
2004-04-14
1997-01-27T18:57Z
2010-14-21T08:12:17.243+07:00
2010-12-21T08:12:17.243Z
2010-12-21T08:12:17.243
2010-11-21T08:12:17.243+07:00
2010-11-01T08:12:17.243+07:00
2010-12-11T08:12:17.243+0700
2010-01-21T08:12:17.243+07:00
2010-11-31T08:12:17.243+07:00
2010-14-21T08:12:17.243-37:00
2010-11-32T08:12:17.243+07:00
2010-14-21T08:12:17.243+0000
2010-14-21T08:12:17.243+1000
2010-11-21T08:12:17.243+0060
2010-14-21T08:12:17.243+1000
2010-14-21T08:12:17.243+1000
Non-Matches
3:00, 2/28/2003
2004-07-12 14:25:59
1900-01-01 00:00:00
9999-12-31 23:59:59
Non-Matches
04-07-12 14:25:59
20004-07-12 14:25
2004/07/12 14:25:59';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);