using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<NUMBER>(.*?)</NUMBER>";
string input = @"<LOCATION>برطانیہ</LOCATION> کے سابق فوجی سربراہ کا کہنا ہے کہ فوجی حکام نے <LOCATION>افغانستان</LOCATION> میں دہشت گردی کے خلاف جنگ کی شدت کا غلط اندازہ لگایا تھا۔
<ORGANIZATION>بی بی سی</ORGANIZATION> کو دیے گئے ایک خصوصی انٹرویو میں <DESIGNATION>جنرل</DESIGNATION> <PERSON>سر پیٹر وال</PERSON> کا کہنا تھا کہ ان کے خیال میں <LOCATION>افغانستان</LOCATION> میں ’محدود‘ مقاصد حاصل کرنے کے لیے موجود ’فوجی افرادی قوت کافی‘ تھی، لیکن اب وہ سوچتے ہیں کہ انھوں نے غلط اندازہ لگایا تھا۔
<DESIGNATION>بریگیڈیئر</DESIGNATION> <PERSON>ایڈ بٹلر</PERSON> <DATE>سنہ دوہزارچھ</DATE> میں <LOCATION>ہلمند</LOCATION> کے فوجی کمانڈر تھے۔
ان کے بقول نہ تو ان کے فوجی اس مشکل جنگ کے لیے تیار تھے اور نہ ان کے پاس لڑائی کے لیے درکار اسلحہ موجود تھا۔
لیکن برطانوی وزارت دفاع کا کہنا ہے کہ انھیں <LOCATION>افغانستان</LOCATION> میں حاصل کی گئی فتوحات پر فخر ہے۔
میرے پیش کردہ منصوبے میں <LOCATION>افغانستان</LOCATION> بھیجے گئے فوجیوں کی تعداد کو محدود مقاصد کے حصول کے لیے کافی قرار دیا گیا تھا لیکن ابھی میں کھل کر اپنے اس اندازے کے غلط ہونے کا اقرار کرتا ہوں۔
<PERSON>جنرل وال</PERSON> <DATE>سنہ دوہزارایک</DATE> سے <LOCATION>افغانستان</LOCATION> میں جاری دہشت گردی کے خلاف جنگ میں اب تک <NUMBER>چار سو ترپن</NUMBER> برطانوی فوجی ہلاک ہو چکے ہیں۔
تک برطانوی فوج <DATE>سنہ دوہزار چار</LOCATION> <DATE>عراق</LOCATION> اور <LOCATION>افغانستان</LOCATION> دونوں محاذوں پر لڑ رہی تھی اور برطانوی فوجی حکام کا خیال ہے کہ انھیں اس وقت اندازہ تھا کہ ان کے پاس ایک سے زیادہ محاذوں پر لڑنے کے لیے درکار وسائل نہیں تھے۔
لیکن اس کے باوجود انھوں نے <NUMBER>تینتیس سو</NUMBER> برطانوی فوجی <LOCATION>افغانستان</LOCATION> بھیجنے کا <ORGANIZATION>نیٹو</ORGANIZATION> سے کیا گیا وعدہ پورا کیا۔
<ORGANIZATION>بی بی سی</ORGANIZATION> ٹو سے بات کرتے ہوئے <PERSON>جنرل وال</PERSON> کا کہنا تھا کہ ’ان کے پیش کردہ منصوبے میں <LOCATION>افغانستان</LOCATION> بھیجے گئے فوجیوں کی تعداد کو محدود مقاصد کے حصول کے لیے کافی قرار دیا گیا تھا لیکن ابھی وہ کھل کر اپنے اس اندازے کے غلط ہونے کا اقرار کرتے ہیں‘۔
<LOCATION>عراق</LOCATION> اور <LOCATION>افغانستان</LOCATION> کی جنگ میں ناقص اندازے:فوج میں ایک مشہور کہاوت ہے کہ بہتر نتائج کی توقع رکھیں لیکن خود کو بدترین نتائج کے لیے تیار رکھیں، لیکن ہم صرف بہتر نتائج کی توقع کر رہے تھے اور خراب نتائج کے تیار نہیں تھے۔
میرا مطلب یہ ہے کہ میرے پاس اس جنگ کے لیے درکار وسائل ہیں نہیں تھے۔
<PERSON>لارڈ رچرڈ</PERSON> <LOCATION>افغانستان</LOCATION> میں برطانوی فوجی بھیجنے کے بعد <LOCATION>برطانیہ</LOCATION> کے فوجی حکام کا خیال تھا کہ <DATE>سنہ دوہزارپانچ</DATE> تک <LOCATION>عراق</LOCATION> کی صورت حال میں بہتری آئے گی لیکن ان کا یہ اندازہ بھی غلط ثابت ہوا۔
سے <DATE>سنہ دو ہزارنو</DATE> تک برطانوی فوج کے <DATE>سنہ دوہزار چھ</DATE> سربراہ <PERSON>لارڈ ڈانٹ</PERSON> کا کہنا ہے کہ ’شاید مجھے اس بات کا اندازہ لگا لینا چاہیے تھا کہ <LOCATION>عراق</LOCATION> کے حالات بہتر نہیں ہوں گے اور <DATE>سنہ دوہزارچھ</DATE> میں <LOCATION>عراق</LOCATION> میں برطانوی فوجیوں کی تعداد <NUMBER>پندرہ سو</NUMBER> تک کم کر دینا درست فیصلہ نہیں تھا۔
<PERSON>لارڈ رچرڈ</PERSON> <DATE>سنہ دوہزارچھ</DATE> اور <DATE>سنہ دوہزار سات</DATE> میں <ORGANIZATION>ایساف</ORGANIZATION> کے <NUMBER>پینتیس ہزار</NUMBER> فوجیوں کی کمانڈ کر چکے ہیں۔
ان کا کہنا تھا کہ اس وقت کوئی یہ ماننے کو تیار نہیں تھا کہ اس جنگ میں شدت آئے گی۔
یہ حقیقت دستاویزات کا حصہ ہے کہ <LOCATION>افغان</LOCATION> جنگ کے اوائل میں یقیناً رکاوٹیں تھیں لیکن <LOCATION>افغانستان</LOCATION> میں حاصل کی گئی کامیابوں پر ہمیں یقیناً فخر ہے۔
برطانوی <ORGANIZATION>وزارت دفاع</DATE> <ORGANIZATION>سنہ دوہزارچھ</DATE> میں <LOCATION>افغانستان</LOCATION> کے <LOCATION>ہلمند</LOCATION> صوبے میں برطانوی فوج کو انتہائی مشکل حالات کا سامنا تھا۔
انھیں طالبان کی جانب سے شدید مزاحمت کا سامنا تھا، ہتھیاروں اور خوراک کی قلت تھی اور ان کا واحد آسرا ہیلی کاپٹر تھے۔
<LOCATION>ہلمند</LOCATION> میں اس وقت کے برطانوی فوجی کمانڈر <DESIGNATION>بریگیڈیئر</DESIGNATION> <PERSON>ایڈ بٹلر</PERSON> کا کہنا ہے کہ ’ہم نہ تو اس جنگ کے لیے تیار تھے اور نہ ہمارے پاس زیادہ ہتھیار اور وسائل تھے، بلکہ سب سے اہم بات یہ ہے کہ ہمارے پاس فتح حاصل کرنے کے لیے واضح حکمت عملی بھی نہیں تھی۔
لیکن برطانوی <ORGANIZATION>وزارت دفاع</ORGANIZATION> کے ترجمان کا کہنا ہے کہ یہ حقیقت دستاویزات کا حصہ ہے کہ افغان جنگ کے اوائل میں یقیناً رکاوٹیں تھیں لیکن <LOCATION>افغانستان</LOCATION> میں حاصل کی گئی کامیابوں پر انھیں یقیناً فخر ہے۔‘
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}