#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(255)\.(0|128|192|224|240|248|252|254|255)\.(0|128|192|224|240|248|252|254|255)\.(0|128|192|224|240|248|252|254|255)"
Local $sString = "255.0.0.0 " & @CRLF & _
"255.128.0.0 " & @CRLF & _
"255.192.0.0 " & @CRLF & _
"255.224.0.0 " & @CRLF & _
"255.240.0.0 " & @CRLF & _
"255.248.0.0 " & @CRLF & _
"255.252.0.0" & @CRLF & _
"255.254.0.0" & @CRLF & _
"255.255.0.0" & @CRLF & _
"255.255.128.0" & @CRLF & _
"255.255.192.0" & @CRLF & _
"255.255.224.0" & @CRLF & _
"255.255.240.0" & @CRLF & _
"255.255.248.0" & @CRLF & _
"255.255.252.0 " & @CRLF & _
"255.255.254.0 " & @CRLF & _
"255.255.255.0 " & @CRLF & _
"255.255.255.128" & @CRLF & _
"255.255.255.192 " & @CRLF & _
"255.255.255.224 " & @CRLF & _
"255.255.255.240 " & @CRLF & _
"255.255.255.248 " & @CRLF & _
"255.255.255.252 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")