import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "v\\d+\\.\\d+\\.\\d+\\.\\d+";
final String string = "36168f5d0262a3c77be966f669483b6dd4b5feb2 refs/tags/v22.10.11.3-develop\n"
+ "35b11636ca48fe4033a6fe8fb023a78094f4536b refs/tags/v22.10.11.2-develop\n"
+ "5e3065a75fbc2a2a7f81ffc63e432d5ce6f482c3 refs/tags/v22.10.11.1-develop\n"
+ "3709d86fd22276ea784ff3a1bb9351ffec737d98 refs/tags/v22.10.10.7-develop\n"
+ "33d06475ba7a2ab8dafb6eb439edb742a118018e refs/tags/v22.10.10.6-develop\n"
+ "de839ee4d535400aaaa7ea2e26d7db144d60aa8a refs/tags/v22.10.10.5-develop\n"
+ "f44477b63cb260dad79de11a99aa1888ecedeaeb refs/tags/v22.10.10.4-develop\n"
+ "2d53acd352bee485ea372fb6f3f5415b1bb65bd8 refs/tags/v22.10.10.3-develop\n"
+ "472f146bf38a8d5db232468fee8c31ab4fe6075d refs/tags/v22.10.10.2-develop\n"
+ "bb58575af76849f965962b29ed6bc19022df8783 refs/tags/v22.10.10.1-develop\n"
+ "c5f5cb120b31e646dcdfe1a3507a47f06db4fca0 refs/tags/v22.10.10.0-develop\n"
+ "2b4d8d78e942c9b4a5a089a814a5ec510618403d refs/tags/v22.10.07.25-develop\n"
+ "0c8eeb9d0edf759fcb18f52376f423b4aa709d83 refs/tags/v22.10.07.24-develop\n"
+ "6d8e520cc0aaf7cea4d3d0f7b9c2d2c772dea055 refs/tags/v22.10.07.23-develop\n"
+ "f9299af9b12b03a672fcddf2acfd1e9072a96f60 refs/tags/v22.10.07.22-develop\n"
+ "d73625323be39a21c55d62f46906d723d172f154 refs/tags/v22.10.07.21-develop\n"
+ "d2e912c62f665e29715de76ecb715266a7c66816 refs/tags/v22.10.07.20-develop\n"
+ "5c2cfd165b09c0278d0a3b0ec60874c77220a5e1 refs/tags/v22.10.07.19-develop\n"
+ "23747bc01c1124573fa761c5ae88b6833c6c4cab refs/tags/v22.10.07.18-develop\n"
+ "b7686f423c5bda9b6b77bd4555bcd7ef3f4b741e refs/tags/v22.10.07.17-develop\n"
+ "31e748884454f60ab9f77912f222a96b0862ba99 refs/tags/v22.10.07.16-develop\n"
+ "34f063a1e498d15296931342769009e3ace66088 refs/tags/v22.10.07.15-develop\n"
+ "aad1b0422f6f71211d2c66e97c5e88666d923427 refs/tags/v22.10.07.14-develop\n"
+ "47eedc45801d869865135fb804ed9c7d68be8924 refs/tags/v22.10.07.13-develop\n"
+ "4299f668eef4254d284ef0f6af14bf3059404477 refs/tags/v22.10.07.12-develop\n"
+ "65c7f411f5c84ab605c299bbf42dcdaa043af57a refs/tags/v22.10.07.11-develop\n"
+ "be70c9ee78e0667ef897918c6cacde7c4d3a3048 refs/tags/v22.10.07.10-develop\n"
+ "b124ab9df7c5fb5e9298c1501fc1b50ebfb9830f refs/tags/v22.10.07.9-develop\n"
+ "4a9eaa4b188167b39200a0a209f70e856211e89b refs/tags/v22.10.07.8-develop\n"
+ "b9327b8a0fe846c7f9ee49125d95d2deb73c330c refs/tags/v22.10.07.7-develop\n"
+ "0b648d33875b7f7b3fd1be682caadcff1a55a61d refs/tags/v22.10.07.6-develop\n"
+ "74b3f187a9993d23456cfd3983233076c3e8750f refs/tags/v22.10.07.5-develop\n"
+ "9f318497675d30b5ac861f6f5040931fb77a7257 refs/tags/v22.10.07.4-develop\n"
+ "22a5935f8eedb97cdbacdb28e8b577f788852dc4 refs/tags/v22.10.07.3-develop\n"
+ "99939991e697f494a6328e737f411f51be75dd0f refs/tags/v22.10.07.2-develop\n"
+ "2660d0b7a243e025a9f8ed70b626cb83b31d5885 refs/tags/v22.10.07.1-develop\n"
+ "4b8489596cbe0f2e8d799f8c51214628970cafe1 refs/tags/v22.10.07.0-develop\n"
+ "b35987cc837d8df98f8dd412dda1cf92c7c05682 refs/tags/v22.10.05.4-develop\n"
+ "9b56abb6e2957be12e2f76c120de7a3a033d84c4 refs/tags/v22.10.05.3-develop\n"
+ "8ab916b32be1b6aceb9284cb8f2c3a62083babb7 refs/tags/v22.10.05.2-develop\n"
+ "c428874e61a15381f9357f0594a7a2da7ddb9e74 refs/tags/v22.10.05.1-develop\n"
+ "1ec1ce52c92023c4d52aad2eac6350feed563b9c refs/tags/v22.10.05.0-develop\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}