use strict;
my $str = '0000000000000000000020180209003010110001 00EXTVVD00000000000000000000000 00000000000000000000000 00000000000000000 000000000000000000000000000000000000000000000000 0000000000 000000000000000 000000000000000000000000000000000000000000 0000BALTES 00 BALTES 000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000 123 ';
my $regex = qr/(?<PMNSEJ>.{10})(?<PMMRN>.{10})(?<PMDPSD>.{8})(?<PMDPSA>.{2})(?<PMCAMI>.{6})(?<PMNIJO>.{4})(?<PMCLI4>.{4})(?<PMCURG>.{1})(?<PMNRPR>.{8})(?<PMNRPR2>.{8})(?<PMNRPR3>.{8})(?<PMINDC>.{4})(?<PMMTX1>.{3})(?<PMREFP>.{8})(?<PMDDEM>.{8})(?<PMMDEM>.{8})(?<PMNOPR>.{1})(?<PMCSP1>.{2})(?<PMCSP2>.{2})(?<PMCSP3>.{2})(?<PMFLG1>.{1})(?<PMFLG2>.{1})(?<PMFLG3>.{1})(?<PMFLG4>.{1})(?<PMDAJC>.{8})(?<PMNOTK>.{9})(?<PMMODP>.{1})(?<PMINDP>.{4})(?<PMTPPE>.{8})(?<PMTCHE>.{8})(?<PMNOTKR>.{9})(?<PMACOT2>.{8})(?<PMDAFA>.{8})(?<PMNRUN>.{3})(?<PMCCLO>.{1})(?<PMRELA>.{6})(?<PMCHOPER>.{1})(?<PMPOSU>.{3})(?<PMCLM>.{2})(?<PMSLM>.{2})(?<PMHMPR>.{4})(?<PMDACO>.{8})(?<PMEPRO>.{3})(?<PMEXTP>.{1})(?<PMIMPL>.{12})(?<PMIMPNQE>.{13})(?<PMDPRO>.{8})(?<PMDRECD>.{8})(?<PMNRPROG>.{6})(?<PMRUNE>.{7})(?<PMNPIE>.{10})(?<PMNRPASS>.{4})(?<PMAPI>.{8})(?<PMCS34>.{10})(?<PMMVTREF>.{1})(?<PMBATT>.{15})(?<PMBATTS>.{2})(?<PMBATTE>.{1})(?<PMUSER>.{10})(?<PMRESE>.{30})(?<PMRESA1>.{10})(?<PMRESA2>.{12})(?<PMTBPE>.{8})(?<PMTRME>.{8})(?<PMTMPE>.{8})(?<PMOSUE>.{7})(?<PMTMUE>.{8})(?<PMTCAE>.{8})(?<PMTPAE>.{8})(?<PMMTBP>.{7})(?<PMMTRM>.{7})(?<PMMTMP>.{7})(?<PMMOSU>.{6})(?<PMMTMU>.{7})(?<PMMTCA>.{7})(?<PMMTPA>.{7})(?<PMMTPP>.{7})(?<PMMTCH>.{7})(?<PMNOTIMPL>.{12})(?<Filler>.{35})(?<Particularites>.{100})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}