#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\(loggingInfo\)|\(beneLoggingInfo\)) - (?<vendorinfo>[^|]*)\|(?<login>[^|]*)\|(?<action>[^|]*)\|(?<timeStamp>[^\|]*)\|(?<tag2>[^\|]*)\|(?<tag6>[^\|]*)\|(?<tag7>[^\|]*)\|(?<tag8>[^\|]*)\|(?<tag9>[^\|]*)\|(?<tag10>[^\|]*)\|(?<tag11>[^\|]*)\|"
Local $sString = "18 Jul 2018 09:05:31,068 INFO (loggingInfo) - Auto CRM|ppope|ApplicationLogin|Wed Jul 18 09:05:31 CDT 2018|CSR agent successfully logged in||Successful||||NA|" & @CRLF & _
"" & @CRLF & _
"22 Oct 2018 08:36:41,164 INFO (beneLoggingInfo) - Beneficiary Administration|TESTWHBENE|APPLICATION LOGIN|Mon Oct 22 08:36:41 CDT 2018|User successfully logged in for Client = 070||SUCCESSFUL||||NA|" & @CRLF & _
"" & @CRLF & _
"22 Oct 2018 00:43:23,845 INFO (loggingInfo) - Inquiry Application|TUSER4444|APPLICATION LOGIN|Mon Oct 22 00:43:23 CDT 2018|User successfully logged in for Client : 580||SUCCESSFUL||||NA|" & @CRLF & _
"" & @CRLF & _
"01 Oct 2018 09:29:33,508 INFO (loggingInfo) - ISIS PersonalPlan|TESTOMAR|APPLICATION LOGIN|Mon Oct 01 09:29:33 CDT 2018|User successfully logged in for Client : 002||SUCCESSFUL||||NA|" & @CRLF & _
"" & @CRLF & _
"24 Oct 2018 13:46:07,647 INFO (loggingInfo) - Web-Billing|egunderson| User Authentication|10/24/2018 01:46:07 PM| User Authentication|NA|True| NA| NA| NA| NA|" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")