$re = '/^(?:[^_]*){1}/m';
$str = '002_part.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);