re = /^(\+?\d{1,4}[\s-]?)?(\(?\d{3}\)?[\s-]?)?\d{3}[\s-]?\d{4}$/m
str = '07708654564
076543 4545 454
+441132382345
0800 456 6788
+93641126157'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end