const regex = new RegExp('(?P<number>\\d+) (?P<word>\\w+)', 'gm')
const str = `ABC 123 Book 456
ZZZ 789 KKK XYZ`;
const subst = `\g<word> \g<number>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);