re = /^(\d{4,5}-(0[1-9]|1[0-2])-(0[1-9]|[12][0-9]|3[01]))$/m
str = '2022-01-01
2022-12-31
2022-1-1
2021-10-27
2022-12-31'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end