$re = '/#\w+/';
$str = '#cookie #recipe #chocolate To do this you have to etc...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);